Network Issue

Incident Report for ValuTrac Software

Resolved

Network Update: The recent network outage has been fully resolved. All systems are now operational and functioning normally. We appreciate your patience and understanding while our team worked to restore service.
Posted Apr 01, 2026 - 09:00 CDT

Identified

We are aware of the network issue and are currently in the process of resolving. We will update the status page shortly.
Posted Apr 01, 2026 - 08:38 CDT
This incident affected: Network Infrastructure.